Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: TLA-1 Factory Second Build

  1. #11
    Cheers for the advice [mention]king casey [/mention].

    Wish Iíd know this before applying... oh well, live and learn.

    Do you know if this is still a problem with lacquer-based paints? Given that timbermate is water-based, perhaps I might be okay... otherwise Iíll just spray on a layer of primer, let it dry, sand it back and go from there if it does present any problems.

  2. #12
    I used ebony Timbermate on my last build to highlight the grain as you have.
    Click image for larger version. 

Name:	120.jpg 
Views:	9 
Size:	462.0 KB 
ID:	38866

    Never tried 'laquer' based paint so can't help there. would possibly test it in an inconspicuous area (like under the scratchplate).

    cheers, Mark.

  3. #13
    Mentor McCreed's Avatar
    Join Date
    Oct 2018
    Location
    AUS
    Posts
    1,688
    ...otherwise Iíll just spray on a layer of primer, let it dry, sand it back and go from there if it does present any problems.
    That's probably a good approach. IF you're getting your Duplicolor from Supercheap, their Primer Surfacer works pretty well.
    I've problems with it spattering a bit, but it has always sanded out just fine I think it may be due to a higher solids content.
    Just be sure to shake often (even between passes) and wipe the nozzle after a couple of passes.
    I complained to SCA about this and got no reply.

    FWIW, I have painted over Timbermate (and primer) and had no shrinkage issues that others have. Maybe I was just lucky.
    Making the world a better place; one guitar at a time...

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •